Analytics
Сейчас в сети: 710
Сейчас в сети: 710
Настройка целей, отслеживание электронной торговли, многоканальные последовательности и тд
Подсказки
star_border
Ответить

Ecommerce - данные отображаются не во всех представлениях

Бакалавр ✭ ✭

Добрый день.

Столкнулся с такой ситуацией: настроили модуль екоммерс - из-за того что оплата может проходить через сторонний сервис (ликпей), то решили сделать отправку данных по транзакции по изменению статуса заказа в CRM. Когда статус completed - отправляем данные по транзакции, если canceled, то шлем сигнал в аналитику про минусовую транзакцию - все это через межурмент протокол.

Все вроде как бы и хорошо, но есть одно но...Данные отображаются не во всех представлениях... Я создал новое представление (скопировал основное пустое), накидал фильтры по айпи и регистру...Потом вижу, что данные в тестовое представление поступают, а в главное нет...Окей - думал, что дело в фильтре обрезающем офисный апишник, так как сигнал шлется с сервера (меняется статус), то думал причина в этом...Удалил этот и все остальные фильтры по айпишникам, кроме своего домашнего:

http://view.xscreenshot.com/c7ed97f49b9d54cf6d68e26d2a366fc7

Но ситуация такая же - в тестовом представлении данные отображаются, а в основном нет (при остальных идентичных настройках)...

 

В чем тут дело? Буду благодарен за помощь в решении вопроса...

1 Ответ экспертаverified_user

Re: Ecommerce - данные отображаются не во всех представлениях

Ведущий участник

Добрый день, Виталий! Из того, что сразу приходит в голову - 1) проверить, включена ли электронная торговля в настройках основного представления, 2) нет ли еще каких-то фильтров в основном представлении, например, на включение хоста.

С уважением, Анастасия

Re: Ecommerce - данные отображаются не во всех представлениях

Бакалавр ✭ ✭
Добрый день!
Сайт был на реконструкции, только добрался к настройке аналитики снова...На тот момент проблему решить не удалось - хотя электронная торговля была включена, на включение хоста тож не было фильтра...
Сейчас сайт доделали и опять передо мной стоит эта проблема...В этот раз настроил с программистом передачу данных через measurement protocol...но проблему это не решило - в тестовом представлении данные отображаются, а в основном нет... Вот как это было:
1. Включил ecommerce (как в основном так и в тестовом):
http://view.xscreenshot.com/5b03b7c6211bc70b0803495092db0963
2. Вот такие фильтры есть в основном представлении (в тестовом их нет):
http://view.xscreenshot.com/084dc99326ef6b9489b6235c3a638a99
3. А вот так данные приходят в тестовое представление:
http://view.xscreenshot.com/60408f25bc386cf32aeb6644fe0eb886
и не приходят в основное (кстате есть и другие представления в них данные екоммерс тоже не поступают):
http://view.xscreenshot.com/92c239c8db75b1c4036570f0d78f8e5a

Может есть еще какие-то идеи почему так? и как это можно исправить?