Analytics
Сейчас в сети: 547
Сейчас в сети: 547
Вопросы настройки тегов, правила и макросы, администрирование GTM
Подсказки
star_border
Ответить

Поставил UA через GTM, на многих страницах не работает. Почему?

Студент ✭

Всем привет!

 

Начинаю работать с сайтом 

vsemktostroit.ru

Поставил GTM. Через GTM поставил UA. Включил в GTM Режим предварительного просмотра, чтобы посмотреть, работают ли мои теги. И увидел, что на страницах каталога они не работают, например:

http://www.vsemktostroit.ru/catalog/fasadnye-paneli/

Tags Not Fired On This Page: Universal Analytics
Соответственно, не работают и события, и формы, и клики - все, что происходит на страницах каталога.
При этом на других страницах сайта UA работает. В чем причина? Почему так может быть, я с таким никогда не сталкивался? Вроде бы код GTM установил правильно...
1 Ответ экспертаverified_user

Утвержденные решения
Лучший ответ.
Решение
Утвердил автор темы Дмитрий Ш
Май

Поставил UA через GTM, на многих страницах не работает. Почему?

Ведущий участник

Надо разобраться просто Веселый

 

Можете написать мне в скайп? Его можно посмотреть вот тут в правой колонкеhttps://www.ru.advertisercommunity.com/t5/user/viewprofilepage/user-id/19

 

*Попрошу вас открыть доступ к GTM




С уважением,
Анатолий

Просмотреть решение в исходном сообщении


Все ответы

Re: Поставил UA через GTM, на многих страницах не работает. Почему?

Ведущий участник

Добрый день, Дмитрий!

 

Скорее всего, тут дело в том, что вы переопределяете объект "dataLayer". Отсюда GTM и не может запустить GA.

Перед добавлением информации в dataLayer сохраняйте все, что было в него записано ранее с помощью кода:

window.dataLayer = window.dataLayer || [];



С уважением,
Анатолий

Поставил UA через GTM, на многих страницах не работает. Почему?

Студент ✭

Здравствуйте, Анатолий!

 

Если честно, не понял Вас. Не програмист. Для меня dataLayer - это способ отправки данных в UAВеселый

 

Может быть, Вы скажете, как должен выглядеть код, чтобы теги срабатывали? Сейчас тестирую работу тегов и они срабатывают через раз.

 

Кстати, я Вас очень давно здесь читаю и могу Вам дать доступ в GTM, UA и даже в админку сайта - к Вам у меня полное доверие. Возможно, так будет проще.

Re: Поставил UA через GTM, на многих страницах не работает. Почему?

Ведущий участник

Да я сам тоже не программист, просто сталкивался с подобной проблемой Веселый

На примере страницы:

 

<script type="text/javascript">

$(document).ready(function(){

window.dataLayer = window.dataLayer || []; //добавить
window.dataLayer = $.eccomerceModule.init({
      addSelector : '.header',
      removeSelector: '',
      buySelector: '',
      dataLayer: "here",
    }); 


console.log(window.dataLayer);
})
</script>

 

Попробуйте такое изменение. Скорее всего, поможет.

 

 




С уважением,
Анатолий

Поставил UA через GTM, на многих страницах не работает. Почему?

Ведущий участник

Спасибо за доверие. Очень приятно Веселый

 

Пока не требуется доступ)




С уважением,
Анатолий

Поставил UA через GTM, на многих страницах не работает. Почему?

Студент ✭

Анатолий, я сделал как Вы сказали:

http://prnt.sc/f0mt7k

Но на страницах каталога UA по-прежнему срабатывает через раз:

http://prnt.sc/f0mq7x

 

На то, что Tag Assistant ругается на GTM, внимания не обращайте - GTM настроен правильно, просто в новых ID 7 символов и Tag Assistant воспринимает это как ошибку. Обещают поправить.

 

Может быть, есть еще какие-нибудь идеи, как заставить его работать? Или теперь только ставить UA без GTM?

Лучший ответ.
Решение
Утвердил автор темы Дмитрий Ш
Май

Поставил UA через GTM, на многих страницах не работает. Почему?

Ведущий участник

Надо разобраться просто Веселый

 

Можете написать мне в скайп? Его можно посмотреть вот тут в правой колонкеhttps://www.ru.advertisercommunity.com/t5/user/viewprofilepage/user-id/19

 

*Попрошу вас открыть доступ к GTM




С уважением,
Анатолий

Поставил UA через GTM, на многих страницах не работает. Почему?

Студент ✭

Добавил Вас в Скайп.